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1 Preface 

This document is a user guide to setup the BMF055 evaluation kit. The kit consists of 

a BMF055 shuttle board connected to a BMF055 breakout board. 

The document describes the modules on the boards and shows the necessary 

connections to power up the kit, program the chip and run the reference examples 

provided by Bosch Sensortec. The examples can be downloaded on Atmel Gallery 

(https://gallery.atmel.com/). 

  

Figure 1 - BMF055 Evaluation Kit 

https://gallery.atmel.com/
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2 BMF055 Breakout Board 

2.1 Components 

 

Figure 2 - BMF055 breakout board's components 

 

1 – USB Power Connecter 

2 – Power source selection pins (USB/ Arduino) 

3 – Programmer/ Debugger JTAG Connector 

4 – BMF055 shuttle board connector 

5 – Customization pins connected to shuttle board connector  

6 – Customization pins connected to Arduino pins 

7 – Arduino Connector 
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2.2 Power 

The board can be powered either via a USB cable or an Arduino board. In the former 

case a jumper should connect pins number 2 and 3 of the power source selection pins. 

In the latter case a connection between pins 1 and 2 are required. 

2.3 BMF055 Shuttle Board 

The shuttle board is a small circuit board with a BMF055 chip mounted on it. In addition 

to the sensor it includes the decoupling/filtering capacitors, reset pull-up resistor 

(RESETN) and a 32 KHz crystal and load capacitors.  

 

Figure 3 - BMF055 Shuttle Board 

2.4 Arduino 

BMF055 breakout board can be connected to an Arduino board as a shield. The male 

connectors at the bottom side provide this possibility. As shown in Figure 4 further 

shields can also be connected to the female connectors. 

 

Figure 4 - Connection to Arduino UNO and an Arduino shield 

2.5 Customization 

The only connections to the Arduino and Shuttle board connectors on the breakout 

board are VDD and GND. The other pins are left unconnected so that users can 

customize how they desire. There are the two sets of male connectors available on the 

board: The inner set (Number 5 in Figure 2) is connected to the shuttle board pins in a 

one-to-one manner and the outer one (Number 6 in Figure 2) is connected to the 

Arduino pins in the same manner. These connectors can be used for the customization.  
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3 Necessary Connections 

3.1 Shuttle board 

The BMF055 shuttle board should be plugged in to the socket on the breakout board 

in a way that pin number 1 of the shuttle is connected to the pin number 1 of the socket. 

3.2 Power 

Either a USB connection or a connection to an Arduino board is required to provide 

power for the board. 

3.3 Power jumper 

If the breakout board’s power is provided by an Arduino board the jumper J11 must 

connect pins number 1 and 2. 

Otherwise, if a USB cable provides the power, the jumper J11 must connect pins 

number 3 and 2. 

3.4 Programmer/ debugger connection 

To program the microcontroller in BMF055 a programmer/ debugger is required. The 

board has a standard JTAG connector to for this purpose.  
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4 Connections for Reference Examples 

In the reference examples provided by BST, the chip uses a USART interface to 

communicate to a host computer or another MCU. It receives commands and sends 

messages via USART. The pin assignment is given in Table 1. 

Table 1 - USART Pin Assignment 

Shuttle Board 
Pin # 

Description 

25 Tx 
24 Rx 

 

Figure 5 shows the necessary connections to power-on and program the sensor to run 

all reference examples. For more information refer to the examples’ application notes. 

 

BMF055 Shuttle Board

RESET

Programmer/ 
Debugger SWDCLK

SWDIO

GND VDDIO

USART Tx

USART Rx

GND VDDIO VDD

 

Figure 5 - Minimum Necessary Connections 

 

 

Figure 6 - Necessary connections to run reference examples 
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5 Quick Setup for Reference Examples 

This chapter gives step by step instructions on how to start running this example on a 

BMF055 Shuttle Board. 

5.1 Software and Extensions 

1. Install the latest version of Atmel Studio from Atmel website 

 Open Atmel Studio 

2. Go to “Tools -> Extension Manager” and install the latest version of Atmel Software 
Framework (Version used in this extension is 3.26.0) 

3. Go to “Tools -> Extension Manager” and search for “BMF055 Shuttle Board – 
[Example]” extension from Bosch Sensortec GmbH (BST) and install it 

4. Go to “Tools -> Extension Manager” and search for “Terminal for Atmel Studio” 
extension from Atmel and install it (It is not necessary to install this extension if you 
are going to use another terminal software or another microcontroller as the host) 

5. Restart Atmel Studio 

6. Go to “File -> New -> Example Projects” 

7. “Below BST – Bosch Sensortec GmbH” find the project named 
“BMF055_SHUTTLE_BOARD_[EXAMPLE] – atsamd20j18a” 

8. Select it and press “OK” button 

9. Read and accept the license agreement and press “Finish” button to create a new 
example project 

5.2 Hardware 

10. Establish the minimum necessary connections; including power, reset and 
programmer/debugger. 

11. Establish a USART connection between the breakout board and the host computer*. 
Use bridges if necessary. 

12. Install required drivers for your virtual COM port. 

13. Go to “Start Menu -> Control Panel -> Device Manager” 

14. Below “Ports (COM and LPT)” find the virtual COM port that you are going to use and 
note the COM port number 

                                                
* It is assumed that the shuttle board would be interfaced to a terminal software running on a 
host computer. 
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15. In Atmel Studio go to “Project -> Properties” and select the tab named “Tool” 

16. Below “Selected debugger/programmer” select the “SAM-ICE” tool (or another 
programmer that you are using). And select “SWD” as the interface and save the 
changes. 

5.3 Run the Project 

17. Open Atmel Studio 

18. In Atmel Studio go to “Build -> Build Solution” 

The build process should succeed with no errors or warnings. (Figure 7) 

19. In Atmel Studio go to “Tools -> Device Programming” (Figure 8) 

- Under Tool Select “SAM-ICE”; under Device select “ATSAMD20J18”; under 
Interface select “SWD” and Click Apply. 

- Go to Memories and click on Erase now. You should see the message “Erasing 
device… OK”. (Figure 9) 

- Go to Fuses, under fuse name find “NVMCTRL_BOOTPROT”, set its value to 
“0x07” and click Program. It should be done with no errors messages. (Figure 10) 

- Close the Device Programming window 

20. Go to “Debug -> Start Without Debugging” (Figure 11) 

21. Wait for the process to be done. 

(Notice the “Ready” message below, on the status bar) 

22. Run and connect the required software (e.g. Terminal) on the host computer if 
required 

5.4 Check the Use-case 

23. Check the application as explained in the example’s application note. 
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Figure 7 - Atmel Studio, Build Project 

 

Figure 8 - Atmel Studio, Device Programming 
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Figure 9 - Atmel Studio, Device Programming, Memories 

 

Figure 10 - Atmel Studio, Device Programming, Fuses 
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Figure 11 - Atmel Studio, Start without Debugging 
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6 BMF055 Shuttle Board 

Bosch Sensortec BMF055 shuttle board is a PCB with a BMF055 Orientation Sensor 

mounted on it. It has the required decoupling capacitors, an external 32 KHz crystal 

and its load capacitors and allows easy access to the sensors pins via a simple socket.  

The shuttle board can be plugged into Bosch Sensortec development tools, BMF055 

Breakout Board, custom designed boards or breadboards. 

6.1 Power 

BMF055 has two distinct power supply pins: 

 VDD is the main power supply for the internal sensors 

 VDDIO is a separate power supply pin used for the supply of the MCU and the 
digital interfaces 

The voltage supply range for VDD is 2.4V to 3.6V and for VDDIO is 1.7V to 3.6V. 

For the switching sequence of power supply VDD and VDDIO it is mandatory that VDD 

is powered on and driven to the specified level before or at the same time as VDDIO is 

powered ON. Otherwise there are no limitations on the voltage levels of both pins 

relative to each other, as long as they are used within the specified operating range. 

6.2 Programming/ Debugging 

Programming and debugging of the chip is done Serial Wire Debug Interface available. 

Any debugger that supports the interface can be used. (e.g Atmel SAM-ICE) 
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6.3 Pin-out 

Table 2 shows the shuttle board’s pin names and their function. 

For more information about possible pin functions please refer to the microcontroler’s 

(ATSAMD20J18A) datasheet 

Table 2 - BMF055 Shuttle Board Pin-out 

Pin 

No. 
Pin Name 

BMF055 Pin 

Connected 

SAMD20 Pin 

Connected 

Description 

1 VDD 3 - VDD 

2 VDDIO 28 - VDDIO 

3 GND 2, 25 - GND 

4 PA19/MISO 21 PA19 Internal SPI MISO 

5 PA16/MOSI 24 PA16 Internal SPI MOSI 

6 PA17/SCLK 23 PA17 Internal SPI SCLK 

7 PB00 6 PB00 GPIO 

8 PA18/CS1 22 PA18 Internal SPI CS1 

9 PA27/CS2 12 PA27 Internal SPI CS2 

10 PB02 4 PB02 GPIO 

11 PB01 5 PB01 GPIO 

12 PA28 10 PA28 GPIO 

13 NC - - Not connected 

14 NC - - Not connected 

15 PB23/INT1 13 PB23 Internal interrupt 1/ GPIO 

16 PA24 14 PA24 GPIO 

17 PA22 16 PA22 GPIO 

18 PA23 15 PA23 GPIO 

19 RESETN 11 RESETN Active Low Reset 

20 PA21 17 PA21 GPIO 

21 PA20 18 PA20 GPIO 

22 PB03/INT2 1 PB03 Internal interrupt 2/ GPIO 

23 NC - - Not connected 

24 PB17 19 PB17 GPIO 

25 PB16 20 PB16 GPIO 

26 NC - - Not connected 

27 NC - - Not connected 

28 NC - - Not connected 

29 PA30/SWCLK 8 PA30 Programming CLK 

30 PA31/SWDIO 7 PA31 Programming IO 
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6.3.1 Internal Signals 

The internal signals are the ones that connect the MCU to the three sensors: 

accelerometer (BMA280), magnetometer (BMM150) and gyroscope (BMG160). The 

internal signals are as follows: 

 SPI MISO: the MISO signal of the SPI bus that connects the MCU and the 
three sensors 

 SPI MOSI: the MOSI signal of the SPI but that connects the MSU to the three 
sensors 

 SPI SCLK: the clock signal of the SPI but that connects the MSU to the three 
sensors 

 SPI CS1: the chip select signal connected to accelerometer and 
magnetometer 

 SPI CS2: the chip select signal connected to gyroscope 

 INT1: interrupt signal connected to INT1 pin of accelerometer and gyroscope 

 INT2: interrupt signal connected to INT2 pin of accelerometer and gyroscope 
 

Please note that, MCU pins connected to the interrupt signals may be used as GPIOs 

only if the corresponding sensor interrupt is not configured. 

For more information regarding the internal signals please refer to BMF055 datasheet. 
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BMF055 Datasheet 

https://ae-

bst.resource.bosch.com/media/products/dokumente/bmf055/BST_BMF055_DS000_0

1.pdf 
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8 Legal disclaimer 

8.1 Engineering samples 

Engineering Samples are marked with an asterisk (*) or (e) or (E). Samples may vary 

from the valid technical specifications of the product series contained in this data sheet. 

They are therefore not intended or fit for resale to third parties or for use in end products. 

Their sole purpose is internal client testing. The testing of an engineering sample may 

in no way replace the testing of a product series. Bosch Sensortec assumes no liability 

for the use of engineering samples. The Purchaser shall indemnify Bosch Sensortec 

from all claims arising from the use of engineering samples. 

8.2 Product Use 

Bosch Sensortec products are developed for the consumer goods industry. They may 

only be used within the parameters of this product data sheet. They are not fit for use 

in life-sustaining or security sensitive systems. Security sensitive systems are those for 

which a malfunction is expected to lead to bodily harm or significant property damage. 

In addition, they are not fit for use in products which interact with motor vehicle systems. 

The resale and/or use of products are at the purchaser’s own risk and his own 

responsibility. The examination of fitness for the intended use is the sole responsibility 

of the Purchaser.  

The purchaser shall indemnify Bosch Sensortec from all third party claims arising from 

any product use not covered by the parameters of this product data sheet or not 

approved by Bosch Sensortec and reimburse Bosch Sensortec for all costs in 

connection with such claims. 

The purchaser must monitor the market for the purchased products, particularly with 

regard to product safety, and inform Bosch Sensortec without delay of all security 

relevant incidents. 

8.3 Application Examples and Hints 

With respect to any examples or hints given herein, any typical values stated herein 

and/or any information regarding the application of the device, Bosch Sensortec hereby 

disclaims any and all warranties and liabilities of any kind, including without limitation 

warranties of non-infringement of intellectual property rights or copyrights of any third 

party. The information given in this document shall in no event be regarded as a 

guarantee of conditions or characteristics. They are provided for illustrative purposes 

only and no evaluation regarding infringement of intellectual property rights or 

copyrights or regarding functionality, performance or error has been made. 
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9 Document History and Modifications 
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